2024 July Release

Additional FeaturesPermanent link for this heading

The Fabasoft Cloud provides following additional features.

Permanent LoginPermanent link for this heading

With the help of a device binding, you can remain permanently logged in to the Fabasoft Cloud App. This is especially useful if you are on the move and your IP address changes frequently.

The permanent login is available both in the Cloud App and on a workstation with Fabasoft Cloud Client installed.

Fabasoft Cloud App

When logging in to the Cloud App, you need to set up a code lock. If you wish, you can also enable authentication methods such as Touch ID or Face ID to unlock the app, depending on the device you are using.

Once you have logged in, you remain logged in until you explicitly log out again. You can also be logged out, for example, if validity restrictions are defined in the organization policy.

In the settings you can manage the code lock and the alternative authentication methods.

Workstation With Installed Fabasoft Cloud Client

You can also perform a device binding on a workstation with installed Fabasoft Cloud Client. To do so, click on the link “Log in your device in the Fabasoft Cloud” in the login dialog. You remain logged in until you explicitly log out again.

Note: For security reasons, a certificate is required to identify the devices used. The corresponding certificate authorities that are allowed to issue computer certificates must be defined in the organization policies.

Logging off devices via the web client

Under “Account menu (your user name)” > “Advanced Settings” > “Devices” you can manage your permanently logged in devices and log out a device if necessary. The next time you use the Fabasoft Cloud on the corresponding device, you will be prompted to log in again.

Edit Common PropertiesPermanent link for this heading

If you select multiple objects and execute the “Edit Properties” context menu command, you can change the common properties of the objects at once. This is possible for scalar properties (e.g. strings), object lists, aggregate lists and aggregates (with scalar values).

Scalar Property

  • If the corresponding property value is the same in all objects, the value is displayed when it is commonly edited. Otherwise, an empty value is displayed.

Object List

  • If the content of the object list is the same in all objects, the content is displayed when it is commonly edited. Otherwise, an empty object list is displayed.
  • If the content of the object list is the same in all objects, the old object list is overwritten by the new object list. Otherwise, you can decide whether the new objects are added to the object list, or whether the old object list is overwritten by the new object list.

Aggregate List

  • If the content of the aggregate list is the same in all objects, the content is displayed when it is commonly edited. Otherwise, an empty aggregate list is displayed.
  • If the content of the aggregate list is the same in all objects, the old aggregate list is overwritten by the new aggregate list. Otherwise, you can decide whether the new aggregate rows are added to the aggregate list, or whether the old aggregate list is overwritten by the new aggregate list. If a key will be violated in the case of adding rows, the corresponding row is ignored.

Aggregate

  • If the corresponding aggregate value is the same in all objects, the value is displayed when it is commonly edited. Otherwise, an empty value is displayed.

Compare ObjectsPermanent link for this heading

Two different objects can be compared. To do so, select any two objects and execute the “Compare” context menu command. If two Microsoft Word documents are involved, the “Compare Content” button is also available in the comparison dialog.

Send as E-MailPermanent link for this heading

Objects can be conveniently sent by e-mail via the corresponding context menu commands:

  • Send Link
    Opens an e-mail with a hyperlink to the object. In order to access the object the recipients of the e-mail must have a cloud account and at least read access is required on the object.
  • Send Public Link
    Opens an e-mail with a public link to the object. No cloud account is necessary to access the object.
  • Send File
    Opens an e-mail with the file itself as an attachment. This command is only available for documents.
  • Send PDF
    Opens an e-mail with a PDF file as an attachment. For documents, the content is converted in a PDF file. For Teamrooms and folders an index is generated.
    Note: Not all objects can be converted in a PDF document.

View as PDFPermanent link for this heading

Via the “Tools” > “View as PDF” context menu command a PDF overview can be generated. Depending on the object type, different contents are generated. For documents, the content is generated as PDF document. For Teamrooms and folders an index with hyperlinks to the contained objects is generated. Otherwise, a PDF document contains the metadata of the object.

Note: In the Teamrooms properties, on the “Content Settings” tab, you can specify whether a cover sheet should be generated for PDF views of documents assigned to the Teamroom. You can select which versions or signatures are to be displayed on the cover sheet.

Support RequestsPermanent link for this heading

You can always submit support requests via the support button. In the account menu (your user name), you can find the “My Support Requests” entry, which leads to the history of your requests. Here you can reply to open requests or close them. In addition, you can create new requests.

If applicable, the support will create product change wishes or requests based on your support requests. You can track these in the “Product Changes” area (State field).

Note:

  • The “My Support Requests” entry is only visible, if you have already submitted a support request via the support button.
  • After submitting your first request, it may take a few minutes that the “My Support Requests” entry becomes available.

Organization-Internal Support Coordinators

The support coordinator team is given access to all support requests in the corresponding context and can perform the same actions as the initiators of the support requests. The support coordinator team can thus assist in the support process in a supportive manner.

Note: A dashboard is available to help the support coordinator team manage support requests. In the “Research” area, the desired support requests can be determined. Activation of this functionality can be requested free of charge from Fabasoft Cloud Support (cloudsupport@fabasoft.com: new window). Subsequently, an organization administrator can authorize the appropriate members in the service desk configuration (accessible via the service desk operations dashboard).

Configuration of Support Coordinators

The configuration of the organization-internal support coordinator teams can be done on the following levels:

  • Organization > “Advanced Settings” widget > “Define Organization Roles” action > Support Coordinator field
  • Teamroom > “Settings” action > “Teamroom” tab > Support Coordinator field
  • App configuration or app room > “Settings” action > “General Settings” tab > Support Coordinator field

The support coordinator team is selected based on the context in which the support request is created.

Organization-Internal Support Teams

By default, support requests submitted via the support button are handled by Fabasoft Cloud Support within the scope of the support agreement. For customer-specific apps, there can be a separate app support that may be involved by Fabasoft Cloud Support.

The app support is specialized in providing assistance with technically and professionally complex customer apps. This is available to you for an additional fee.

For the organization-internal support coordination you can define support teams that primarily handle support requests in the respective context. For this purpose, the support team can be defined at the following levels: organization, app configuration, app room, or Teamroom. This allows you to provide your organization members with an internal contact person without losing the ability to forward support requests to Fabasoft Cloud Support if necessary.

The designated support team receives workflow activities for the support requests brought in. The requests can either be answered directly or additional support requests can be submitted to Fabasoft Cloud Support. With the answers from Fabasoft Cloud Support, further processing of the original support requests is possible.

Note: A dashboard is also available to help the support team manage support requests. Activation of this functionality can be requested free of charge from Fabasoft Cloud Support (cloudsupport@fabasoft.com: new window). Subsequently, an organization administrator can authorize the appropriate members in the service desk configuration (accessible via the service desk operations dashboard).

Configuration of Support Teams

The configuration of the organization-internal support teams can be done on the following levels:

  • Organization > “Advanced Settings” widget > “Define Organization Roles” action > Support Team field
  • Teamroom > “Settings” action > “Teamroom” tab > Support Team field
  • App configuration or app room > “Settings” action > “General Settings” tab > Support Team field

The support team is selected based on the context in which the support request is created.

Configuration Support Dialog

The support dialog for support requests to the organization's internal support team can be customized accordingly by an organization administrator:

Organization > “Advanced Settings” widget > ”Define Logo” action > Use Logo und Background Color in Support Dialog field

Manage Support Requests

When a support request is submitted, the defined support team receives the workflow activity “Edit”. As a support team member, you can perform the following steps:

  • Set Responsible User
    Defines the responsible user (necessary to be able to perform the further work steps). Thus, it is visible in the service desk dashboard by whom the request is processed.
  • Reply
    Allows you to enter a response to the submitter. The answer can be marked as a suggested solution.
  • Close
    Closes the support request. If necessary, a message can still be added.
  • Further Information Required
    Allows you to get more information from another user.
  • Request at Fabasoft Support
    If the problem cannot be solved internally, a new support request can be generated for Fabasoft Cloud Support. As soon as this request has been processed, the original support request is put in your worklist again.

Service Desk Dashboard

A dashboard is also available to help the support team manage support requests. Activation of this functionality can be requested free of charge from Fabasoft Cloud Support (cloudsupport@fabasoft.com: new window).

The service desk dashboard is divided into the following areas:

  • My Support Requests
    Shows all requests assigned to the current support employee or not yet assigned to a support employee.
    • grey symbol
      The request has the state “Work in Progress” and no support employee is assigned.
    • no symbol
      The request has the state “Work in Progress” and a support employee is assigned.
    • yellow symbol
      The request has the state “Waiting for Customer”.
    • green symbol
      The request has the state “Closed”.
  • Support Requests in Progress
    Shows all requests with status “Work in Progress” regardless of the support employee.
  • Requested at Fabasoft Support
    Shows all current requests to the Fabasoft Cloud Support.
  • Recently Processed
    Shows the last hundred requests on which an action was performed.
  • Product Changes
    Shows the product changes. If a support request leads to a story or a defect, a product change can be created by the Fabasoft Cloud Support or app support. You can use the Status field to track the implementation status.
  • Research
    Allows searching for product changes, support requests and support request reports.
  • Support Reports
    Displays the generated support reports. The “Create Support Reports” action can be used to create evaluations of the processed requests in a specific time period.

Working with a WebDAV ClientPermanent link for this heading

The Fabasoft Cloud supports the platform-independent WebDAV standard. This way it is possible to access documents in the Fabasoft Cloud via WebDAV client applications (e.g. Microsoft Windows Explorer or Apple Finder).

The data is accessible via following WebDAV URL: <URL of the cloud>/folio/webdav

Example: https://at.cloud.fabasoft.com/folio/webdav

If you use the default WebDAV URL, “Home” is used as the base folder. Alternatively, you can also specify an object and, if necessary, a property directly as the base. In this way, path length problems can be avoided, for example. In general, the property can be omitted, since usually only one list per object is visible as a WebDAV resource.

Syntax:

.../webdav/[<object>-<property>]

Example:

.../webdav/[COO.1.506.3.4961]

.../webdav/[COO.1.506.3.4961-COO.1.1001.1.324006]

Mapping a network drive using the Fabasoft Cloud Client

  1. Open the context menu of the Fabasoft Cloud Client by right-clicking the notification symbol in the taskbar of the operating system.
  2. Click the “Open Cloud Network Drive” command.
  3. For access, a password for applications is needed. By clicking “Open Network Drive (New Password), a password for applications is automatically generated. The password is stored in both in the Fabasoft Cloud and in the credential manager of the operating system.
    If a valid password is stored on the local computer, the network drive is directly opened.

The network drive is opened in the Microsoft Windows Explorer or Apple Finder and this way you have access to your folder structure in the Fabasoft Cloud.

Note:

  • In the web client, you can revoke the password for applications by opening the account menu (your user name) and clicking the “Advanced Settings” > “Access for Applications” command. Click the “Revoke” button in the corresponding row with the description “Network drive for <computer name>”.
  • You cannot view the generated password for applications that was created with the Fabasoft Cloud Client.
  • In the credential manager of the operating system only one, the last current password is stored. If, for example, you map a network drive manually as described below and store the credentials in the operating system permanently, the password will be used further on also in the Fabasoft Cloud Client, even if you previously generated an own password.

Mapping a network drive manually

Alternatively, you can map a network drive also manually. This is, for example, necessary on smartphones since no Fabasoft Cloud Client is available.

  1. For access, a password for applications is needed. Create a password by opening the account menu (your user name) and clicking “Advanced Settings” > “Access for Applications”. Create a password valid for “Network Drive (WebDAV)”. Additional information can be found in chapter “Access for Applications”.
  2. Switch to the corresponding third-party product and define the WebDAV URL (see the beginning of this chapter), your e-mail address (used for the cloud log-in) and the generated password for applications. In the following, you will find a description for the third-party products Microsoft Windows Explorer and Apple Finder.
    Microsoft Windows Explorer
    Click “Tools” > “Map network drive”. Select a drive letter and enter the WebDAV URL in the Folder field. Click “Finish”. If no valid password is stored on the local computer, enter your e-mail address and the password for applications. If you store the credentials permanently, the password is used also for further connections.
    Apple Finder
    Click “Go” > “Connect to Server”. Enter the WebDAV URL in the Server Address field and click “Connect”. If no valid password is stored on the local computer, enter your e-mail address and the password for applications. If you store the credentials permanently, the password is used also for further connections.

Notes for working with WebDAV

  • If you import a folder on top-level or in a folder that is not assigned to a Teamroom, the folder will be converted into a Teamroom in the Fabasoft Cloud.
  • Documents cannot be imported on top-level or in a folder that is not assigned to a Teamroom.

Time TravelPermanent link for this heading

The time travel allows you to view documents and metadata to specific times in the past. Via the “Time Travel” > “Start Time Travel” action you can start the time travel. Use the timeline to reach easily and quickly the desired point in time.

  • “Start Time Travel”, “Continue Time Travel”, “End Time Travel”
    Select the version you want to view or end the time travel. As an alternative to selecting a version, you can specify a point in time.
  • “Save Current Version”
    Saves a version of the current state. The version can also be treated as “release version”. This way, team members with read access can only see this version. A new release version replaces a possibly present release version.
  • “Clean up Versions”
    You can delete versions that are no longer needed.
    • How many versions should be kept?
      You can define the maximum number of versions you want to keep.
    • How many days versions should be kept?
      You can define how many days the versions should be kept at maximum.
    • Apply these rules automatically
      You can specify that in the future too many or too old versions will be automatically deleted.
      Note: To disable automatic execution, run the "Clean up Versions" action again. Remove all values, disable this option and click "Clean up".
    • “Select Versions”
      You can explicitly select and delete versions via the “Select Versions” button. The button is displayed if there are at least two versions.
  • “Compare”
    Compares the selected version with an arbitrary other version. The contents of Word documents can also be compared.
  • “Restore”
    The current version is replaced by the selected version.
  • “Delete”
    You can delete the currently displayed version that is no longer needed.

Note: The timeline is not operable with the keyboard.

CalendarPermanent link for this heading

Calendars allow you to manage events and tasks, and to share them with other team members. In addition, you can access your calendars with third-party products via CalDAV.

Creating a CalendarPermanent link for this heading

To create a calendar, proceed as follows:

  1. Navigate in the desired Teamroom.
  2. Open the context menu of an empty part of the content area and click “New”.
  3. In the “Calendar” category, select the “Calendar” entry.
  4. Enter a name and click “Next”.

In the calendar, you can create events and tasks. The calendar can also be downloaded as an iCalendar file (ICS).

Creating an EventPermanent link for this heading

To create an event, proceed as follows:

  1. Navigate in the desired calendar.
  2. Click the “Create Event” action.
  3. Enter the data of the event.
  4. Click “Create”.
    Note: If you have specified at least one attendee, you can use the “Create and Send” button to create the event and also send an e-mail to the defined attendees with the event as an ICS file.

Note:

  • An event can be sent subsequently via the “Send Event” context menu command.
  • If a sent event is updated or deleted, you can send an event update or event cancellation.
  • Via the sent e-mail the event can be opened, accepted, provisionally accepted or declined. The respective status is displayed for the event in the Attendees field.

Access via CalDAVPermanent link for this heading

Calendars can also be accessed by third-party products via CalDAV. For access, a password for applications is required. If you have not created a password for CalDAV, create one now (see chapter “Access for Applications”).

If your third-party product supports calendar lists, you can manage them in the Fabasoft Cloud. Otherwise, you can embed a calendar directly via the Calendar URL (properties of the calendar).

To manage the calendar list, proceed as follows:

  1. Click the account menu (your user name) and then click “Advanced Settings” > “Calendar”.
  2. In the Calendar field, add the wanted calendars. Via the URL webcals://<server>/<vdir>/caldav (e.g. webcals://at.cloud.fabasoft.com/folio/caldav) you can access the calendar list in a corresponding third-party product.
  3. The calendar shown in the Default Calendar field can also be accessed via the URL webcals://at.cloud.fabasoft.com/folio/caldav/home.
  4. Click “Save” to apply the changes.

Note:

  • Depending on the third-party product, you may replace webcals:// by https://.
  • Calendars can also be managed by the context menu commands “Add to Calendar List” and “Remove From Calendar List”.

If you are using Apple iOS, you can include your calendar list as follows:

  1. Navigate to “Settings” > “Passwords & Accounts” > “Add Account”.
  2. Select the entry “Other” > “Add CalDav Account”.
  3. Enter your account information.
    • Server
      webcals://<cloud server>/<vdir>/caldav
      Example: webcals://at.cloud.fabasoft.com/folio/caldav
    • Username
      The e-mail address you use to log in to the Fabasoft Cloud.  
    • Password
      The generated CalDAV application password (see chapter “Access for Applications”).
  4. Now you can access your Fabasoft Cloud calendar list with the Apple Calendar app.

Address BookPermanent link for this heading

When using the contact management, you can manage your contacts in contact rooms and address lists. In addition, you can access your address book list via CardDAV with third-party products.

You can find your address book list under “Account menu (your user name)” > “Advanced Settings” > “Address Book”. In the Address Book List field, add the wanted contact rooms or address lists. Via the URL https://<server>/<vdir>/carddav (e.g. https://at.cloud.fabasoft.com/folio/carddav) you can access the address book list in a corresponding third-party product.

CardDAV

Access to contacts is also possible via third-party products such as “Apple Contacts”, which support the CardDAV standard. A password for applications is required for access. If you have not yet created one for CardDAV, create one (see chapter “Access for Applications”).

Access is possible via the central CardDAV URL. For example:

  • https://at.cloud.fabasoft.com/folio/carddav
  • https://de.cloud.fabasoft.com/folio/carddav
  • https://ch.cloud.fabasoft.com/folio/carddav

Microsoft Outlook

The “Open Cloud Address Book” context menu command of the Fabasoft Cloud notification symbol can be used to include the address book list in Microsoft Outlook.

NewsfeedPermanent link for this heading

With the newsfeed, you can keep your team members up to date with the latest news.

Creating a NewsfeedPermanent link for this heading

To create a newsfeed, proceed as follows:

  1. Navigate in the desired Teamroom.
  2. Open the context menu of an empty part of the content area and click “New”.
  3. In the “Collaboration” category, select the “Newsfeed” entry.
  4. Enter a name and click “Next”.

Writing Posts in the NewsfeedPermanent link for this heading

Any user who has change rights in the Teamroom can write posts in the newsfeed. These posts are readable for all team members. For a newsfeed, it can be configured that team members with read access can also write posts.

To write a post in the newsfeed, proceed as follows:

  1. Navigate in the newsfeed.
  2. Enter the text in the textbox and possibly add an attachment.
  3. Click “Send”.

Any user can remove their posts. Team members with full control can remove any post.

Note:

  • A maximum of 2000 characters can be entered.
  • Team members with read access cannot add attachments.
  • Posts can be commented.
  • If you share a link, starting with http://, https:// or ftp://, it will be displayed as a hyperlink. If you follow this hyperlink, it will be opened in a new window.
  • With <code></code> source code can be displayed formatted.

WatermarksPermanent link for this heading

It can be defined that documents in a Teamroom are automatically converted to secured PDF documents with a definable watermark. Team members with read access only see the PDF documents whereas team members with change access or full control see the source documents.

To define a watermark for a Teamroom, proceed as follows:

  1. Navigate in the desired Teamroom.
  2. Open the “Permissions” tool and click “Watermark Settings”.
  3. In the Use Watermarks field, select “Yes”.
  4. Define the desired settings for the watermark. With the Watermark for All Users option, you can test the settings by yourself.
  5. Click “Next”.

Note: Watermarked Teamrooms and assigned objects cannot be duplicated by users who only have access to PDF documents with watermarks.

CAD Objects and 3D ViewerPermanent link for this heading

Manage your 3D CAD files and benefit from the new preview and 3D viewer functionality.

Note: Available as add-on product.

CAD Object

To be able to store 3D models, the “CAD Object” object class is available. Using the "View in 3D Viewer" action, you can display the 3D model in the integrated 3D viewer.

3D Viewer

The integrated 3D viewer allows you to view 3D models interactively in an overlay. You can rotate, zoom and position the 3D model using the keyboard and mouse.

  • Rotate
    Mouse: drag with pressed left mouse button
    QWERTY keyboard: Q, E or Left, Right, Up, Down
  • Zoom
    Mouse: mouse wheel
    QWERTY keyboard: W, S or +, -
  • Position
    Mouse: drag with pressed right mouse button
    QWERTY keyboard: A, D, X, Z
  • A tree view of the elements of the displayed 3D model can be displayed. The individual elements/element groups can be shown or hidden via the respective check boxes. The element selected in the tree view is highlighted in the 3D view for better orientation.
  • It is possible to hide or show the navigation cube.
  • The camera type (first person, orbit, plan view) can be selected via the “Camera Control” button. Depending on the camera type, it differs how the 3D object is moved with mouse or keyboard interaction.

Converting Multimedia FilesPermanent link for this heading

Convert your images, videos and audio files in different formats.

ImagesPermanent link for this heading

You can export images in different formats in the file system or in the clipboard.

To export an image, proceed as follows:

  1. Navigate to desired image and mark it.
  2. Open the “Clipboard” menu and click “Download Image”.
    Note: Make sure that the menu bar is displayed (“account menu (your user name)” > “Basic Settings” > “Show Menu Bar”).
  3. Define the size and target format.
  4. Click “Copy Image to Clipboard”, “Copy Link to Clipboard” or “Download Image”.

Note: In the “Clipboard” menu, you will additionally find the menu entries “Copy Image for Presentation” and “Copy Image for E-Mail” that export the marked image in different formats to the clipboard.

Video and Audio FilesPermanent link for this heading

You can convert video files to MP4, OGV or WEBM. For audio files, MP3 and OGG are available.

To convert a video or audio file, proceed as follows:

  1. Navigate to the desired multimedia file.
  2. On the context menu of the multimedia file, click “Save as <format>”.

The conversion runs in the background and may take longer depending on the size of the source file. The result of the conversion can be found in the properties of the multimedia file, on the “Content” tab in the File in Different Formats field.

Follow-UpsPermanent link for this heading

When using the follow-up functionality, an e-mail can be sent to a user or a process can be started at a particular time.

To define a follow-up, proceed as follows:

  1. Navigate to the desired object.
  2. On the context menu of the object, click “Tools” > “Create Follow-Up” or “Manage Follow-Ups” (at least one follow-up is already defined).
  3. If you mark the follow-up as personal (only valid for the "Send e-mail" action), it will not be visible to other users.
  4. Select the Action that should be executed.
    • Send E-Mail
      Define Recipients for the e-mail. In the Message field, you can specify the e-mail text.
    • Start Process
      Define the process that should be executed.
      Note: The process has to be released for the organization.
  5. If applicable, enter a reason. The text is displayed as a suffix of the follow-up name and calendar event.
  6. Define the date of the follow-up and whether it should be repeated. For more information, refer to the “Point in Time” and “Repetition” sections below.
  7. Click “Next”.

Upon reaching the follow-up date and after processing the automatic task the defined action will be executed.

Note:

  • For non-personal follow-ups, substitutes and successors will be considered.
  • “Immediately after last change on/at” can also be selected for the execution time. Changes within the first 10 seconds after definition of the follow-up are ignored. After that, the next change to the object is considered.

Point in Time

You can either specify an explicit date or let the date be calculated based on a base date field of the object. Optionally, the execution date can be redefined if the base date is changed.

Repetition

It is also possible to repeat follow-ups. The following cases can be distinguished.

Explicit date or date is not recalculated when the base date is changed

You can define a repetition rule that is applied starting with the execution time.

  • Unit
    Defines the unit of the interval (e.g. day or month).
  • Interval
    Defines the interval between the repetitions (number).
  • Repeat Until
    Defines the end time of the repetitions (infinite, explicit date, date value of a property).

Date is recalculated when the base date is changed

The background task is rescheduled after the selected action is executed and the base date is changed. Only Repeat Until can be defined as a repetition rule.

Follow-Ups Dashboard

You can manage the follow-ups in the follow-ups dashboard. The dashboard is divided into the following areas:

  • Calendar
    Shows all follow-ups of the “My Follow-Ups” list.
  • My Follow-Ups
    Shows the follow-ups that were created by you or in which you are entered as the recipient. You can also store other follow-ups by yourself. You can use the “Settings” action to adjust the filter criteria and to find the CalDAV URL, which you can use to integrate your follow-ups as a calendar in Microsoft Outlook, for example.
  • Further Follow-Ups
    Shows follow-ups determined by you. You can define the search criteria using the “Determine Follow-Ups” action.

Cloud Mail ImportPermanent link for this heading

Using the cloud mail import, you can automatically query mailboxes and import e-mails. In this process, cloud mail folders allow you to filter e-mails based on conditions. You can use cloud mail dispatchers to assign e-mails to different folders.

A typical scenario would be that you query the e-mails in your mailbox and select a cloud mail folder as the target folder. In the cloud mail folder, you set a condition that only e-mails that contain the word "Invoice" in the subject should be stored. In a cloud mail dispatcher, define the cloud mail folder as the source folder and store all e-mails with "Car" in the subject in a folder. The destination folders of the first dispatcher can be source folders for further dispatchers. Thus, a dispatcher cascade can be built until all e-mails have been sorted into the desired folders.

Note: “Cloud Mail Import”, “Cloud Mail Folder” and “Cloud Mail Dispatcher” can be created in a Teamroom.

Cloud Mail Import

You can define the following settings:

E-Mail Server tab

  • Name
    The name of the cloud mail import.
  • Protocol
    Defines the protocol to be used to access the e-mail server.
  • Server
    Defines the fully qualified domain name of the e-mail server on which the mailbox is hosted.
    Note: The data required in the following for communication with the e-mail server can be found, for example, in the configuration of your e-mail client or in the documentation of your provider.
  • When using the Microsoft Graph API, an administrator must create an app in your Microsoft portal that defines the required API access rights. To do this, navigate to “Microsoft Entra ID” and register a new app.
    Allow “Accounts in this organizational directory only”.
    As redirect URI for the platform “Web” define https://at.cloud.fabasoft.com/folio/cmigraphauthcodecallback (use de or ch instead of at based on the data location).
    Assign the following Microsoft Graph API permissions (delegated permissions): Mail.Read, Mail.ReadWrite and User.Read.
    • Microsoft Directory (Tenant) ID
      Defines the “Directory (Tenant) ID” of your Microsoft environment.
    • Microsoft Application (Client) ID
      Defines the “Application (Client) ID” of the app defined in your Microsoft environment.
    • Microsoft Client Secret (Value)
      Defines the “Client Secret (Value)” of the app defined in your Microsoft environment.
  • Port
    Defines the port for accessing the e-mail server. The input is optional when using the standard port for the respective protocol (e.g. 110 for POP3).
  • User Name
    Defines the user name to be used to access the mailbox.
  • Password
    Defines the password to be used to access the mailbox.
  • Mailbox Folder
    Defines a special mailbox folder to be queried.
    Note: When using the IMAP protocol or Microsoft Graph API, you can specify a specific folder to be retrieved.
  • Recipient Filter
    If an e-mail address is specified, only e-mails sent to the specified e-mail address will be imported (To, CC, BCC).
  • Delete After Retrieval
    Defines whether the e-mails are deleted from the e-mail server.
    • When using the IMAP protocol
      If this field is enabled, all e-mails are retrieved from the mail server and then deleted. If this field is disabled, only unread e-mails are retrieved and then marked as read.
    • When using the POP3 protocol
      This field cannot be disabled. All e-mails are retrieved and then deleted.
    • When using the Microsoft Graph API
      If this field is enabled, retrieved e-mails are deleted from the mail server.
  • Target Folder
    Defines the folder in which the retrieved e-mails are stored. If no folder is specified, the "Cloud Mail Import" itself is the target folder.

Automation tab

  • Retrieve Automatically
    Defines whether e-mails should be retrieved automatically.
  • Interval
    Defines the time interval for automatic retrieval.
  • Automation Enabled for
    Shows all your cloud mail imports and dispatchers with automatic execution.

Context Menu Commands

  • Retrieve E-Mails
    You can manually retrieve the e-mails.
  • Enable Automatic Retrieval/Disable Automatic Retrieval
    You can enable or disable the automatic retrieval.
  • Authenticate
    When using the Microsoft Graph API, you must authenticate yourself and allow access.
  • Reset Synchronization Status
    When using the Microsoft Graph API, if you reset the synchronization status, again all e-mails will be considered the next time you retrieve them and not just the new e-mails since the last synchronization.

Cloud Mail Folder

You can specify the following settings:

Cloud Mail Folder” tab

  • Name
    The name of the cloud mail folder.
  • Maximum Age (Days)
    E-mails older than the specified days will be deleted (creation date).
  • Maximum Number of E-Mails
    If the number of e-mails exceeds the specified maximum number, they will be deleted.
  • Conditions
    Only e-mails that match the defined conditions will be stored (OR conjunction). A condition consists of a property (e.g. “Subject”) and a pattern (any string). The value of the property must contain the pattern string to match the condition (case-insensitive).
    Note: The conditions are checked when e-mails are to be stored in the cloud mail folder via the cloud mail import.
  • Target Folder (Not Matching)
    Defines the folder where e-mails that do not match the conditions will be stored.
    Note: This folder should always be defined in order not to lose any e-mails.

Cloud Mail Dispatcher

You can specify the following settings:

“Dispatcher” tab

  • Name
    The name of the cloud mail dispatcher.
  • Conditions
    E-mails are placed based on the defined conditions (OR conjunction). A condition consists of a property (e.g. “Subject”) and a pattern (any string). The value of the property must contain the pattern string to match the condition (case-insensitive).
  • Source Folder for E-Mails
    Defines the source folder from which e-mails are distributed.
  • Target Folder (Matching)
    Defines the target folder for e-mails that match the conditions.
  • Target Folder (Not Matching)
    Defines the target folder for e-mails that do not match the conditions.

Automation tab

  • Dispatch Automatically
    Defines whether e-mails should be dispatched automatically.
  • Interval
    Defines the time interval for automatic dispatching.
  • Automation Enabled for
    Shows all your cloud mail imports and dispatchers with automatic execution.

Context Menu Commands

  • Dispatch E-Mails
    You can manually dispatch the e-mails.
  • Enable Automatic Dispatch/Disable Automatic Dispatch
    You can enable or disable the automatic dispatching.

Data ImportPermanent link for this heading

You can use an Excel file to create or update objects with the desired metadata. If you want to create objects of different object classes, you need one Excel file per object class.

Note: As an alternative to the Excel file, you can also use a CSV file with UTF-8 character encoding.

To import data records from an Excel file, proceed as follows:

  1. For example, in a Teamroom, open the “Tools” menu and click “Import Data”.
    Note: Make sure that the menu bar is displayed (“account menu (your user name)” > “Basic Settings” > “Show Menu Bar”).
  2. Select the Excel file you want to import and click “Import”. A description of the required data structure of the Excel file can be found below.
  3. Select the container and the list in which the objects are to be created or updated. For example, the objects can be created in the Contents list of a Teamroom.
  4. Select the object class for the newly created objects.
  5. If necessary, select a category (incoming category, form category) to be assigned to the newly created objects.
  6. If the container already contains objects, select a key that identifies the objects. This allows you to update existing objects. The key can also consist of several properties. If you do not specify a key, new objects will always be created. In general, the Import ID (objexternalkey) is used as the key.
  7. Click “Next” to import the data records.

New objects are created from the data records or existing objects are updated.

Format of the Excel File

  • For each property that is to be filled with a value, a column is required.
  • In the header row, the respective property is defined based on the reference of the property.
    Note: To determine the reference of a property, open the properties of a sample object. Using the shortcut Ctrl + Shift + # you can show or hide the references of the properties. Clicking on the reference copies it to the clipboard. The short reference (part after the colon) can be used if it is unique (instead of for example COOSYSTEM@1.1:objexternalkey just objexternalkey). Alternatively, the multilingual name of the property can be specified, but this is discouraged to ensure uniqueness.
  • Each additional row represents the values of an object.
    Note: If possible, always use a unique ID to determine the objects to be referenced.
  • You can also define an OverrideKeys column in which you can enter column names separated by commas or one below the other (Alt + Enter). This results in the following behavior:
    • If the OverrideKeys column does not exist, empty values are taken over and lists are overwritten.
    • If the OverrideKeys column exists and the column name is entered, empty values are taken over and lists are overwritten.
    • If the OverrideKeys column exists and the column name is not entered, empty values are not taken over and new entries are added to lists.

Example table:

objexternalkey

objname

objsubject

OverrideKeys

Import1

Object Name 1

Subject of object 1

Import2

Object Name 2

Subject of object 2

objname,objsubject

Note:

  • The specified properties must be modifiable for the values to be imported. For example, Created by is not modifiable.
  • The changes must be permitted:
    • Mandatory fields cannot be emptied.
    • The uniqueness of lists is maintained.
    • Objects of non-permitted object classes cannot be stored.
  • In order to assign several objects to a list, the individual objects must be specified one below the other in the corresponding cell (Alt + Enter).

Mapping the Values

The import will attempt to convert the specified strings to the appropriate property data types, although not all data types are supported.

Procedure:

  • Enumeration
    • Reference of the enumeration value
    • Name of the enumeration value
    • Numeric value of the enumeration value
  • Date/Time
    • ISO 8601
    • dd.mm.yyyy HH:MM:SS
  • Currency
    • Currency symbol (e.g. EUR, USD) + space + value
    • Value + space + currency symbol
  • Object
    • Fabasoft Cloud ID
    • MX URL with Fabasoft Cloud ID (../mx/COO.a.b.c.d)
    • Reference with prefix #
    • Import ID with prefix ?
    • User (member or external member of the organization if not specified by e-mail address).
      • E-mail address
      • Object name
      • Last name + space + first name
      • First name + space + last name
    • Organization element (team, organizational unit, external organization)
      • Object name
    • Country
      • ISO 3166 ALPHA-2
      • ISO 3166 ALPHA-3
      • Multilingual name
    • Organization (contact management)
      • E-mail address
      • Object name
    • Contact person (contact management)
      • E-mail address
      • Object name
    • Processing state
      • Multilingual name
    • Category
      • Multilingual name
    • Terms
      • Multilingual name
      • Multilingual name of synonyms
    • Object (allowed in the property)
      • Object name
      • Multilingual name
  • In all other cases, an attempt is made to assign the value to the property.

AuditingPermanent link for this heading

“Auditing” gives you the opportunity to reconstruct requests on objects. There are not only shown changes of properties. For example, you can also find out when and by whom an object was read, or rights were granted.

Creating a Search Folder for Audit LogsPermanent link for this heading

To create a search folder for audit logs, proceed as follows:

  1. Navigate in the desired Teamroom.
  2. Open the context menu in an empty part of the content area and click “New”.
  3. Click the “Search Folder for Audit Logs” entry.
  4. Enter a name and fill out the fields depending on your search criteria.
    Note: If you do not define a Teamroom, only a limited time range can be investigated. If an organization is defined, you can extend the time interval up to 3 months, if an audit originator is defined, you can extend the time interval up to 7 days, otherwise only a maximum of two hours can be investigated.
  5. Click “Next“.

Navigate in the search folder and click the “Refresh” action. All objects matching your search criteria will be displayed (except for objects that have already been deleted). Use the “Export Audit Log” action to check the audit log entries of deleted objects.

Note:

  • You can create search folders for audit logs only if you have been authorized in the organization policies.
  • To change the search criteria, click “Properties” in the context menu of the search folder and adjust the search criteria accordingly.

Showing Audit Log EventsPermanent link for this heading

To show the audit log events of an object, proceed as follows:

  1. Navigate in the search folder for audit logs.
  2. Mark the desired object.
  3. Open the “Object” menu and click “Show Audit Log”.
    Note: Make sure that the menu bar is displayed (“account menu (your user name)” > “Basic Settings” > “Show Menu Bar”).

All events are displayed that occurred during the specified period. The “Show Changes” context menu command, can be used to read the versions of the object.

Note: Alternatively, you can also navigate to the desired object, select it and execute the “Tools” > “Show Audit Log" menu command.

Exporting the Audit LogPermanent link for this heading

To export the audit log events as CSV file, proceed as follows:

  1. Navigate in the search folder for audit logs.
  2. Click the “Export Audit Log” action.
  3. After the report generation has finished click the “Download” button, to export the CSV file.

Adjusting Access Rights After a Membership ExclusionPermanent link for this heading

If a member's organization membership is terminated, all access rights to the organizational Teamrooms are revoked and, if a successor has been defined, the successor is entered in the Teamrooms instead of the former member. Users who have all rights in the affected organizational Teamrooms and are members of this organization will be notified by e-mail. The successors will also be informed by e-mail. The links in the e-mails can be used to check the Teamrooms and make any necessary adjustments.

Note: When terminating a membership in external organizations, organizational units or teams, those with full control in the Teamroom are also informed by e-mail, if the Teamroom is restricted to the affected external organization, organizational unit or team.

For Teamrooms of other organizations the following applies:

  • If the user's membership in his or her main organization is terminated, users with full control in Teamrooms of other organizations will also be informed about the exclusion and, if applicable, about the successor. The access rights can be manually adjusted by a user with full control.
  • If the user's membership in one of his or her non-main organizations is terminated, only Teamrooms that are restricted to the affected organization are handled.

Handle Infected DocumentsPermanent link for this heading

A virus scan is carried out regularly. If viruses are found, the respective Teamroom administrators are informed by e-mail. Using the “Handle Infected Document” action, Teamroom administrators can either mark the document as incorrectly classified or download and clean it. Be aware of the risks involved in downloading infected files to your computer. Cleaned documents can be uploaded again using the “Upload” action.